gyp_main.py:错误:没有这样的选项: - no-parallel
gyp_main.py: error: no such option: --no-parallel

运行npm install来安装sinopia项目的开发依赖项,我得到这个node-gyp配置错误:> fs-ext@0.4.5 install / home / remi / _projects / gitlab / SWAP / sirap-private-npm / ...

TweenLite typescipt导入
TweenLite typescipt import

我通过npm下载了GSAP包,现在我想通过TypeScript将TweenLite类导入我的应用程序。 可以通过编写require('gsap')导入所有GSAP来完成; 它运作良好。 但在 ...

Sails Js expexxted标识符错误
Sails Js unexpexted identifier error

您好我是sails js中的新手我正在尝试CRUD使用它,但我在我的函数索引中遇到意外错误。 我不知道我在哪里做错了。 // Usercontroller.js文件module.exports = {...

npm运行gulp参数
npm run gulp with parameters

我已经开始学习gulp而且我正在处理一个小问题。 我有以下文件://测试gulp文件var gulp = require(“gulp”),uglify = require(“gulp-uglify”); //脚本任务// ...

npm创建了大量的文件,我做错了什么?
npm creates huge number of files, what am I doing wrong?

我阅读PhpStorm手册的这一部分的方式,添加一个开发工具,我可以做到这一点:如果一个工具是一个文档或一个测试框架,那些将不再需要重新...的工具。

为什么我在'npm install ibmconfig'上获得ERR 404?
why do I get ERR 404 on 'npm install ibmconfig'? #bluemix nodejs server

我下载了我的IBM bluemix nodeJS应用程序,并尝试安装项目的所有依赖项。 出于某种原因,ibmconfig抛出异常。 但是,URL可以在浏览器中正常工作。 ...

如何将缓冲区保存到S3 Bucket中
How to save a buffer into an S3 Bucket

我的要求是将图像缓冲区保存到S3存储桶中。 我正在使用gm节点模块将图像转换为缓冲区。 但我的主要问题是我需要将缓冲区直接发送到......

如何阅读Firebase Node.js模块?
How to read Firebase Node.js module?

我正在运行聚合物入门套件应用程序,我需要一个firebase连接,但我不知道为什么浏览器说需要是未定义的。 $ npm install firebase --save var Firebase = require(“...

配置webpack以从node_modules中选择jquery.min.js而不是jquery.js
Config webpack to pick jquery.min.js instead of jquery.js from node_modules

在创建bundle.js文件时,有没有办法告诉webpack从node_modules / jquery文件夹中选择jquery.min.js而不是jquery.js?

未找到Autoprefixer命令
Autoprefixer command not found

我使用Autoprefixer时遇到问题我尝试使用安装:npm install -g autoprefixer我尝试在我的项目中安装它:npm install autoprefixer --save-dev但似乎没有...

npm错误:无法建立隧道套接字,因为= connect ETIMEDOUT
npm error: tunneling socket could not be established, cause=connect ETIMEDOUT

我有一个使用Rails框架的应用程序,并将AngularJs作为前端的一部分实现。 我把所有东西都推到Heroku并安装了Heroku Toolbelt,但是当我尝试迁移时......

无法让“npm install -g”在任何软件包上运行(AppData / Roaming / npm总是为空)
Cannot get "npm install -g" to work on any packages (AppData/Roaming/npm always empty)

在Windows 7企业版上运行nodejs。 每当我安装一个需要-g访问的node_module时,根据经验我知道它应该在%AppData $ / Roaming / npm中创建一个* .bat文件,但对于...

在Node.js中操作图像
Manipulation of an Image in Node.js

我想改变图像的方向,如从纵向到横向,反之亦然。 我尝试使用许多可用的npm包:* rotate-image * image-rotate * jpegorientation * ...

错误在node.js应用程序上使用npm安装'connect'包
error installing 'connect' package with npm on node.js app

我正在尝试在运行ubuntu的aws实例上为node.js应用安装'connect'包。 以下是我得到的回应。 有谁知道问题是什么? npm http GET https:// ...

安装Gulp的问题
Problems Installing Gulp

我正在努力让Gulp在我的Ubuntu系统上工作。 当我运行安装Gulp的命令时,没有报告错误,但是例如在安装后运行gulp -v不起作用。 npm -v 2.11.3 ......

包管理器NPM和node.js完整性
Package manager NPM and node.js Integrity

我刚刚在NPM上创建了一个新包(这非常简单),我对如何保持包的完整性感兴趣。 任何人都可以发布一个新版本的软件包,或者这个......

如果我将模块发布到npm,则fs不会获取文件
fs doesn't get file if i publish module to npm

当我将模块发布到npm时,我遇到了问题。 这是文件结构: - node_modules - lib - file.txt - index.js - package.json我这样使用它:var a = fs.readFileSync('。/ lib / ...

我可以使用npm为基于PHP的站点安装Fabric.js吗?
Can I install Fabric.js using npm for a PHP-based site?

我目前正与另外两个人一起开展一个项目。 我们需要创建一个小网站,允许您上传照片,然后在其上面输入自定义文字作为叠加层。 根据我...

无法升级 - slimerjs失踪......?
Unable to upgrade - slimerjs missing...?

我正在使用节点v5.0.0和npm v3.3.9在OSX(El Capitan)上运行。 如果我尝试升级:npm升级我得到以下错误:npm WARN弃用lodash@0.9.2:lodash @ <2.0.0不再...

“npm list”中“无效”标签的含义是什么?
What does the "invalid"-tag mean in `npm list`?

给出以下npm列表输出片段:...├─┬glove@6.0.2无效│├─┬inmplight@1.0.4││└──grappy@1.0.1│├──inherits@2.0.1│ ├──minimatch@2.0.10│└──once@1.3.3 ......我问自己:“......

Npm碰撞版本号但npmjs没有更新
Npm bumped version number but npmjs doesn't update

今天早些时候发布我的第一个npm包。 将其设置为v0.0.0。 我修复了一个bug并完成了:npm version patch -m“Bumped to version%s”它现在被设置为v0.0.1我推送到github(带标签)但是......

git不存储.npmrc文件权限
.npmrc file permission are not stored by git

在我的项目中,我想使用.npmrc文件指向私有存储库。 从npmrc的文档中我们读到:注意:因为本地(每个项目或每个用户).npmrc文件可以包含...

从node_module(npm包)中包含css?
Include css from node_module(npm package)?

我在客户端使用React,我需要包含来自npm包的css。 在我拿走它们并复制到我当地的导演之前。 我也在工作草案中使用GULP

尝试使用jspm安装bower软件包时出错
Getting an error when tried to install bower packages with jspm

当我尝试使用以下命令安装像devextreme这样的bower软件包时使用以下命令jspm install bower:devextreme,我收到错误注册表bower未找到我应该更新任何jspm设置还是安装...

如何将MongoDB集合中的数据存储为堆?
How to store data in a MongoDB collection as a heap?

我正在为我的Web应用程序使用MEAN堆栈,其中包含可以最有效地存储和作为堆结构访问的数据。 我的应用程序将有很多电话(大约几百...

如何为`npm init`设置默认测试命令?
How do I set the default test command for `npm init`?

我知道我可以这样做:npm config set init.author.email me@mycompany.com npm config set init.license UNLICENSED设置用于使用npm init创建新package.json的默认值。 但是我怎样才能设置......

NodeJS db-migrate TypeError:无法读取null的属性“1”
NodeJS db-migrate TypeError: Cannot read property '1' of null

我刚刚将nodejs包db-migrate安装到现有的nodejs项目中。 似乎在与DB的连接方面正确配置了所有内容。 Database.json:{“...

在package.json中使用git标签(对于git依赖项)
Use of git tags in package.json (for git dependencies)

有可能某些如何获得git依赖项的更新行为,就像npm包一样? 所以我有git依赖:“dependencies”:{“my-module”:“github:me / my-module”}并希望它更新......

为非Web开发人员管理npm软件包安装
Managing npm package installation for non-web developers

我在一个项目中工作,我是C ++开发人员团队中唯一的前端开发人员。 当我们构建发布变体时,我希望C ++开发人员运行Web构建过程(npm install,...

NPM包已经过时了,有没有办法改变它的版本?
NPM package has outdated dependency, is there a way to alter its version?

刚刚从0.10迁移到节点4.1.2。 其中一个软件包是通过npm安装错误安装的,因为node-gyp的某个依赖项存在问题,因此有很多版本已经过时。 ...

在rails中或作为独立应用程序部署Angular2演示应用程序?
Deploy Angular2 demo app within rails or as standalone app?

我目前正在学习Angular2并完成了快速入门和英雄教程。 我总是以“npm start”启动这些应用程序。 我已经在ruby on rails上创建了一个后端应用程序,还...

npm安装停止工作
npm install stops working

我已经检查了很多stackoverflow的答案,但还没有发现任何可以解决我当前问题,运行npm安装后安装只是停止一段时间后,这是命令的结果:...

Nodejs module.exports和Shorthand if / else
Nodejs module.exports and Shorthand if/else

行'undefined'!= typeof Customer是什么? 客户:module.exports在以下代码片段中做什么? 为什么要包装(function(){})中的所有内容? 我似乎无法破译它......

npm如何运行?
how does npm run work?

键入npm run <command>时会发生什么? 是否将<command>传递给sh shell,例如:sh -c <command>,并在shell中添加了其他局部变量,即...的路径

使用grunt进行自定义项目
Using grunt for a custom Project

我使用Grunt作为“JS Task Runner”。 节点安装在“C:/ Program Files”中。 NPM安装在C:/ users / Peterson / appdata / roaming / npm中。 在npm文件夹中的Grunt,Bower和Grunt-cli。 创造一个......

没有安装mongoose npm
failing to install mongoose npm

我正在安装mongoose作为npm。 我收回了一堆错误。 我从一篇关于类似问题的帖子中做了npm install -g node-gyp的npm安装。 但是,我的问题没有......

使用jspm安装npm库时出错
Error installing an npm library with jspm

我正在尝试使用jspm安装react-bootstrap-datetimepicker并且我收到此错误:$ jspm install npm:react-bootstrap-datetimepicker密码:查找npm:react-bootstrap -...

npm install mongoose:shasums.txt缺失
npm install mongoose: shasums.txt missing

我正在尝试安装Mongoose但它失败了。 npm install mongoose --save这是错误:> kerberos@0.0.15安装D:\ Hans \ Playground \ MultiVision \ node_modules \ mongoose \ node_modules \ mongodb \ ...

NPM错误找不到现在的“es2015” - babel / node / react
NPM error can't find present "es2015" - babel/node/react

部署到Heroku时,我收到以下NPM错误。 我的项目是一个mern堆栈。 错误:无法找到相对于目录“/ app”的预设“es2015”包似乎安装正确,我......

使用npm模块编译coffeescript测试
Compiling coffeescript test with the npm module

是否可以使用npm模块编译一串coffeescript,我一直在寻找各处,似乎找不到任何好的答案。

NPM从package.json安装依赖项
NPM installing Dependencies from package.json

我有点困惑。 在我的笔记本电脑上,当我构建我的项目时,我的package.json在我安装时填充了依赖项。 它看起来像这样:“main”:“webpack.config.js”,“依赖”:{...

使用sails时,我是否需要在package.json中显式grunt
Do I need explicitly grunt in package.json when using sails

我有sails app和main package.json如下。 如果帆也有它们,我真的需要所有那些咕噜声。 特别是如果帆在版本0.4.5中咕噜咕噜,这里我有0.4.2无论如何没有咕噜声......

npm列表只有dev或prod依赖项
npm list only dev or prod depedencies

我试图在文档之后只使用package.json中的生产依赖项所以我正在做npm list -depth 0 -prod或npm list -depth 0 -only prod但是npm似乎忽略它而且它...

在Windows上安装Telerik Appbuilder CLI时出错
Error installing Telerik Appbuilder CLI on Windows

我正在尝试将telerik appbuilder CLI安装到我的Windows机器上。 我得到的第一个错误是无法找到cl.exe。 我通过修改我的Visual Studio社区安装来解决这个问题...

npm如何连接到存储库并下载组件?
how npm connects to repository and downloads the components?

我是nodejs / npm的新手,现在想在我的实验室中安装一些像bower / gulp这样的组件。 我受到企业防火墙的限制,因为实验室在没有任何互联网访问的情况下具有高度安全性 ...

安装npm时出现错误代理
error proxy on install npm

我在google.com上寻找这个问题的解决方案,我在stackoverflow.com上阅读了有关此主题的所有相关问题。 但找不到正确的答案。 问题是对于每个命令npm ...

npm:找出哪些依赖项使用给定的包(间接)
npm: find out which dependencies use a given package (indirectly)

我目前正在开发一个node.js项目,我一直在开发期间跟上最新的节点版本。 现在节点6已经出局了,我想知道我是否也可以做出这个决定....

npm run script:node server.js && mocha test
npm run script: node server.js && mocha test

我的用例非常简单:首先我要运行node server.js(启动我的Node.js应用程序) - 并且在Node启动后 - 我想运行mocha test(对之前提供的API运行一些测试...

找不到插件“karma-mocha-reporter”。
Cannot find plugin "karma-mocha-reporter". npm install works, but error persist.

一旦我尝试添加插件:['karma-jasmine','karma-mocha-reporter'],我的karma.config.js我收到此错误:C:\ git \ angularjs \ .bin> karma start karma .config.js 11 ...
1 2 3 4 5 6 7 108 109