使用pip在运行时安装程序
Using pip to install a program while running

我有一个带插件功能的程序,如果我不使用它,我不想安装setup.py中的所有插件。 它们只应在它们的配置中激活时安装...

将我的仓库拉到另一个位置时,所有安装有pip的Library都会消失?
All Library's installed with pip disappear when pulling my repo to another location?

我正在使用ubuntu 15.04,每次我将我的一个repos从bitbucket拉到我计算机上的另一个位置时,我无法运行该程序,因为我收到了导入错误。 然后我尝试使用pip冻结然后我得到...

pyvenv安装错误的pip版本
pyvenv installs wrong pip version

我正在使用pyvenv env创建virtualenv,但已安装的pip版本已过时。 我可以手动更新虚拟环境中的pip,但我希望自动拥有正确的版本。 没有......

在virtualenv上的pip安装请求[安全]无法构建用于加密和cffi的轮
pip install requests[security] on a virtualenv fails building wheel for cryptography and cffi

虽然遵循这个并且在虚拟环境中使用django,我注意到在使用pip时会出现InsecurePlatformWarning。 搜索引导我到这个SO帖子[我无法链接],但随后......

pip install -r:只安装新包
pip install -r: install only new packages

假设我的requirements.txt文件是:diff-match-patch == 20121119 django-braces == 1.4.0 django-crispy-forms == 1.4.0我使用以下命令安装所有软件:pip install -r requirements ....

如何使用最新版本的pip下载或安装Gitlib作为独立库?
How to download or install Gitlib as a standalone library with recent versions of pip?

这是一个非常简单的问题,但我完全坚持如何解决它。 我甚至找不到下载的方法。 该网站不提供任何在pypi外面下载的东西......

使用自制软件时,Pip不会安装到python 3中?
Pip won't install into python 3 when using homebrew python?

所以我有一个使用pyvenv-3.3创建的virtualenv,我认为设置pip将东西安装到virtualenv的路径中。 但是,在我被virtualenv激活之后,我得到了以下输出:...

更改通过pip安装的应用程序的目录
Change directory for app which is installed via pip

我正在使用virtualenv和pip。 是否可以将通过pip安装的应用程序移出virtualenv并进入我的django应用程序文件夹?

如何知道哪个Python受到pip命令的影响?
How to know which Python gets affected by pip command?

如果我有几个Python安装,我想知道命令python执行哪一个,我可以做python -c“import sys; print(sys.prefix)”我怎么能(或程序)确定哪个...

在本地安装包
Install package locally

我使用python的pip来安装包。 现在我想安装scipy,它已经安装在系统上,但是旧版本和我无法访问的系统的一部分。 如果我试试......

使用自定义证书文件查找代理
Pip behind a proxy with a custom certificate file

pip的代理设置可以通过--proxy命令行选项或全局配置文件(即Unix中的$ HOME / .config / pip / pip.conf,$ HOME / Library / Application Support / pip / pip)指定。 ...

如何在Windows机器上的Python 3.4中安装lxml
How to install lxml in Python 3.4 on Windows machine

我一直在花这些时间。 我是Python的新手,无法看到解决方案可能是什么。 我有Python 3.4,并希望使用.docx,它需要lxml。 到目前为止我所做的工作流程是:我去......

如何为共存的Python 2.7 / 3.4设置pip?
How to setup pip for coexisting Python 2.7/3.4?

我现在在Windows 7 PC上使用Anaconda Python 3.4。 最近我试图按照高性能Python这本书的教学来学习一些分析技巧。 为此我需要使用pip ......

使用pip安装MySQL-python时,结果是以下输出,无法安装MySQLdb
While installing MySQL-python using pip am ending up with the following output and unable to install MySQLdb

_mysql.c(42):致命错误C1083:无法打开包含文件:'config-win.h':没有这样的文件或目录错误:命令'“C:\ Users \ mahendra.gaur \ AppData \ Local \ Programs \ Common \ Microsof t \ Visual C ++ for ...

在python 3.4.3上安装软件包时出现奇怪的错误
Strange error while installing packages on python 3.4.3

当我尝试安装软件包时,会发生这种非常奇怪的异常。 我使用命令提示符找到Python目录(python34),然后运行pip命令...

隐藏“需求已满足”警告
Hide "Requirement already satisfied" warning

我们有一个shell脚本,可以自动准备虚拟环境,然后在其中运行测试。 部分脚本安装要求:pip install -r requirements.txt脚本运行时...

PIP从命令行引发SyntaxError
PIP raising SyntaxError from command line

我尝试使用以下命令安装PIP:sudo yum install python-setuptools sudo easy_install pip sudo pip install supervisor安装时,出现了许多语法错误......

pip包 - 手动下载
pip Packages -- Manual Download

从R到Python进行一些数据科学实践我想下载某些软件包。 具体来说,我开始关注Jinga2和Jupyter的一些工作。 我落后了......

在python3.2中安装pip <v8
Install pip<v8 in python3.2

我无法在python3.2中安装pip。 最新版本的pip(v8.x)似乎不再支持python3.2了。 所以我试过:sudo python3 get-pip.py'pip <8'但它似乎仍然安装v8.x. ...

使用pip和macport安装了错误的virtualenv路径
Wrong virtualenv path installed with pip and macport

我无法使用pip和macport在Mac OS 10.9上安装virtualenv。 用pip install virtuanenv安装后我发现virtualenv安装在/ opt / local / Library / Fraemworks / Python中....

使用PIP安装pyside - 找不到nmake
installing pyside using PIP - nmake not found

我想使用PIP包管理器安装PySide。 但它收到此错误消息,说它没有找到nmake。 这并不奇怪,因为我没有安装MSVC,也不打算。 安装......

pip3失败但是pip与virtualenv一起工作正常
pip3 fails but pip works fine with virtualenv

我想为python3安装virtualenv。 我一直试图在过去的一个小时内解决这个问题并且没有运气。 root @XXXX:〜#pip3 install virtualenv下载/解包virtualenv无法获取...

如何通过pip安装Pygame for Python 3.5?
How to installing Pygame for Python 3.5 via pip?

我正在尝试为python 3.5 32bit安装Pygame。 我了解到我可以使用pip命令打开网站上提供的.whl文件。 问题是我尝试了多种方法,但......

在我的Windows 7机器上安装django 1.4.3时获得多个语法错误
getting multiple syntaxerrors when installing django 1.4.3 on my windows 7 machine

我尝试在安装了Python 3.3的Windows 7机器上安装django 1.4.3。 我使用了pip install django,但在安装时遇到了几个SyntaxError:无效的语法消息。 一个例子 ...

如果它有多个子目录,如何从git安装pip包?
How to install a package with pip from git if it has multiple subdirectories?

我正在使用具有以下结构的repo:foo / bar / setup.py foo / bar / mypackage我正在尝试使用以下内容安装此软件包:pip install git + ssh://git@github.com/。 ..

如何在IPython-Notebook上安装oauth2
How to install oauth2 on IPython-Notebook

我想在IPython-Notebook上导入oauth2。 当我这样做:import oauth2发生错误:ImportError:没有名为'oauth2'的模块对于常规安装,我应该先安装模块:pip ...

如何为Python 2.7和Python 3.4设置两个不同的pip版本?
How to set two different pip versions for Python 2.7 and Python 3.4?

目前,似乎我的pip是Python 3.4的点子我希望这个版本的pip用于Python 2.7,而Python 3.4版本的pip是pip3。 我怎样才能做到这一点? 我试过了 ...

使用pip设置django-nonrel
Setting up django-nonrel using pip

我正在尝试以正确的方式安装django-nonrel - 并且能够重现该过程。 我已经使用pip安装了django-nonrel - 如下所示:pip install git + https://github.com/django-nonrel / ...

无法在virtualenv中安装旧的wxPython(无法解压缩文件/无法确定存档格式)
Unable to install older wxPython within virtualenv (Cannot unpack file / Cannot determine archive format)

在Python 2.6.6内置的virtualenv中,我正在尝试pip安装这里找到的2.8.10.1 2.6 unicode dmg:pip install -Iv http://sourceforge.net/projects/wxpython/files/wxPython/2.8。 10.1 / ...

OSX:安装python包时出错
OSX: error when installing python packages

目前,由于gcc-4.0错误,我无法安装任何Python包。 我将复制两个我正在获得的错误示例(一个使用pip,另一个使用手动setup.py构建/安装方法):...

Pip:无法获取pypi的URL并确认ssl证书
Pip: Could not fetch URL for pypi and issue confirming the ssl certificate

我最近刚刚安装了运行pip(9.0.1)的python(3.6.1),并且在我尝试安装软件包时出现以下错误:pip install cx_Oracle收集cx_Oracle无法获取URL ...

全新安装后无法运行`jupyter notebook`
Can't run `jupyter notebook` after fresh installation

我做了:pip install --upgrade pip pip install jupyter jupyter notebook我得到以下错误:Traceback(最近一次调用最后一次):文件“/ usr / local / bin / jupyter-notebook”,第7行,在<.. 。

Sagemath的BeautifulSoup4
BeautifulSoup4 in Sagemath

我正在尝试用BS4进行网络抓取,然后在Sage 6.2(Lion 10.7.5)中对结果进行一些代数工作。 我假设/Applications/Sage-6.2.app/Contents/Resources/sage/sage -i ...

bash脚本中的pip -r错误
pip -r error at in bash script

#!/ bin / bash -e pip install -r requirements.txt当我执行上面的脚本时,我收到以下错误信息; 例外:Traceback(最近一次调用最后一次):文件“/usr/lib/python2.7/dist-packages/pip / ...

Python:ImportError:没有名为numpy的模块
Python : ImportError: No module named numpy

我正在尝试运行bash脚本,我一再发生以下错误文件“/usr/share/fsl/5.0/bin/aff2rigid”,第75行,在<module>中从numpy import * ImportError:没有模块...

pip install -U mock:错误
pip install -U mock : Error

我试图在Python中为单元测试安装mock。 我在终端上使用以下命令来安装mock:$ sudo pip install -U mock我收到以下错误:OSError:[Errno 1] ...

在pip中指定模块所需的最小python版本
Specifying the minimum python version required for a module in pip

有没有办法指定在pip中安装模块所需的最小python版本? 我正在尝试将包发布到pypi。 python setup.py sdist upload -r pypi我是命令...

使用pip无法安装Seaborn,即使在手动安装所有依赖项后[重复]
Cannot install Seaborn using pip, even after manually installing all the dependencies

$ pip install seaborn收集seaborn使用缓存的seaborn-0.7.0.tar.gz从命令python setup.py egg_info完成输出:Traceback(最近一次调用last):文件“<string&...

pip安装出错
Error with pip install

我试图通过pip install aplpy安装模块aplpy,但我不断收到错误消息(见这里)。 看起来与Anaconda存在某种冲突; 你有什么建议......

如何在Python 2.7上使用Python 3.6进行python pip安装
How to python pip install for Python 2.7, having using Python 3.6 before on Windows

我想问一下当我以前安装和使用Python 3.6时如何使用pip install for Python 2.7? (*我现在必须在Windows上安装Python版本)pip install ... keep ...

Bluemix:如何升级pip?
Bluemix: How to upgrade pip?

当我在bluemix上运行我的python应用程序时收到此警告:您使用的是pip版本7.1.0,但版本8.1.0可用。 如何在我的cf app中运行像“pip install --upgrade pip”这样的shell命令?...

conda安装似乎没有访问最新的包版本
conda install does not seem to have acces to latest package version

当我在我的conda environement上安装keras时,它似乎没有安装最新版本,因为我有2.0.5并且当我运行conda update时它看起来是2.0.8(https://pypi.python.org/pypi/Keras) ...

使用pip安装特定的tensorflow分支
Installing specific tensorflow branch with pip

我正在研究这个用tensorflow v0.10.0rc0测试过的项目。 我不想承担任何依赖风险,我对这个语法版本感到有点困惑(而不是不那么神秘的1.0,1.1,...

安装requirements.txt错误,语法错误 - python2
Install requirements.txt error, syntax error - python2

我有这个requirements.txt文件:Django == 1.9.4 EbookLib == 0.15 SpeechRecognition == 3.3.3 argcomplete == 1.1.0 argparse == 1.2.1 beautifulsoup4 == 4.4.1 chardet == 2.3.0 lxml = = 3.5.0 pdfminer == 20140328 python -...

powershell来运行pip
powershell to run pip

我想运行python模块升级vie powershell脚本。 第一线工作。 但我不知道如何正确地将文件读入第二个pip行。 我收到此错误:找不到...

python + pip安装bson错误
python+pip install bson error

我想安装第3库 - > bson。 但接下来的错误,谁知道为什么? #pip install bson收集bson使用缓存的bson-0.5.2.tar.gz从命令python setup.py egg_info完成输出:...

pip升级TooManyRedirects异常
pip upgrade TooManyRedirects exception

我正在尝试在docker容器中pip install --upgrade pip,但是,我收到错误:Exception:Traceback(最近一次调用最后一次):File“/usr/lib/python2.7/dist-packages/pip/ basecommand.py”,...

“/lib/python2.7/site-packages/不支持.pth文件”在MacOS上安装pip
"/lib/python2.7/site-packages/ does NOT support .pth files" installing pip on MacOS

我在我的mac上使用pip遇到了一些问题,并完全卸载了它。 现在,当我尝试重新安装它时,运行$ sudo easy_install pip我得到:TEST FAILED:/lib/python2.7/site-packages/不...
1 2 3 4 5 6 7 51 52